Schaltjahre mit Excel schnell ermitteln

29. Februar, Schalttag 2016
© mitifoto / Fotolia.com

2016 – das ist ein Jahr mit einer geraden Zahl. Aber ist es auch ein Schaltjahr? Mit Excel können Sie auf diese Frage sehr schnell antworten. Die Funktionen REST und JAHR machen es möglich. Dafür müssen Sie nur ein einzelnes Datumsfeld auswählen und die entsprechenden Formeln hinterlegen. Wir stellen Ihnen zwei Varianten vor, wie Sie Schaltjahre mit Excel berechnen: einmal mithilfe des gregorianischen Kalenders und ein anderes Mal über die Anzahl der Tage im Februar.

Wie werden Schaltjahre berechnet?

Welche Jahre sind überhaupt Schaltjahre? Im Grunde gilt ja die Regel: Alle Jahre, die ohne Rest durch 4 teilbar sind, bekommen einen zusätzlichen Tag, um die Abweichungen zwischen dem kalendarischen und dem astronomischen Jahr auszugleichen. Aber es gibt eine wichtige Ausnahme, die nur wenig bekannt ist. Denn die vollen 100 Jahre sind von der Schaltjahresregelung ausgenommen. 1900 ist also zwar ohne Rest durch 4 teilbar, aber nach dieser Bestimmung doch kein Schaltjahr.

Und um es noch ein wenig komplizierter zu machen, gibt es auch hier wieder eine Ausnahme, die alle vollen Jahrhunderte betrifft, die durch 400 teilbar sind. Diese sind dann abweichend von der ersten Ausnahmen doch wieder Schaltjahre. 2000 ist so ein Fall. Es ist zwar ein volles Jahrhundert (dürfte also nach der ersten Regel kein Schaltjahr sein), aber durch 400 teilbar – und hat damit doch wieder einen Tag mehr.

Ein Schaltjahr ist also zusammengefasst wie folgt gekennzeichnet:

  1. Die durch 4 teilbaren Jahre erhalten zusätzlich einen Schalttag. Danach wären beispielsweise 1900, 2000 und 2004 Schaltjahre.
  2. Die durch 100 teilbaren Jahre bekommen diesen Schalttag wieder weggenommen. Es bliebe im Beispiel nur 2004 als Schaltjahr übrig.
  3. Schließlich wird bei den durch 400 teilbaren Jahren der Schalttag wieder zugefügt. Damit ist schließlich neben 2004 auch 2000 wieder ein Schaltjahr.

Schaltjahre mit Excel ermitteln: über den gregorianischen Kalender

Bezogen auf die Zelle A1, würde dies bedeuten, dass eine Formel mit verschiedensten Bedingungen erforderlich ist, die diese Regel und die Ausnahmen aufnimmt und eine entsprechende Schaltjahr-Information zurückgibt:
=WENN(REST(JAHR(A1);400)=0;“Schaltjahr“;WENN(UND(REST(JAHR(A1);4)=0;REST(JAHR(A1);100)<>0);“Schaltjahr“;“kein Schaltjahr“))

Schaltjahre mit Excel ermitteln: über Tage im Februar

Sie können Schaltjahre mit Excel aber auch über eine andere Formel berechnen, wie Sie am Beispiel von Zelle A2 sehen:
=WENN(TAG(DATUM(JAHR(A2);3;0))=29;“Schaltjahr“;“kein Schaltjahr“)

Achtung: Fehler in Excel

Bei diesem Lösungsansatz müssen Sie jedoch aufpassen, denn „Microsoft Excel nimmt fälschlicherweise an, dass das Jahr 1900 ein Schaltjahr ist …“ und  bei Microsoft wird auch begründet, warum dies so ist. Schuld an diesem Dilemma ist demnach nicht Microsoft, sondern die Software-Firma Lotus, die in ihrer ersten Version im Jahr 1983 in dem damaligen Tabellenkalkulationsprogramm Lotus 1-2-3 das Jahr 1900 als Schaltjahr ausgerufen hat. Aus Gründen der Kompatibilität habe man damals diese „Konvention“ übernommen. Und weil der Fehler bis heute erhalten geblieben ist, könne man den Fehler auch nicht mehr so einfach korrigieren.

  1. Philip Käser

    Die Formel:
    =WENN(TAG(DATUM(JAHR(A2);3;0))=29;“Schaltjahr“;“kein Schaltjahr“)
    Ist fehlerhaft!

    1. sollte die Formel wenn sie funktionieren würde so heißen:
    =WENN(TAG(DATUM(JAHR(A2);2;0))=29;“Schaltjahr“;“kein Schaltjahr“)

    Die 3 im Datums Teil, gibt hier den Monat März an, wir wollen aber den Februar.

    Zumal dem ich mir nicht vorstellen kann, wie man „nur mit dem Datum in Zelle A2“ berechnen will, ob der Februar 29 Tage hat.

  2. Jackie251

    Herr Käser bitte die Fakten erstmal checken bevor man so eine Anklage erhebt.
    Die gegebene Formel ist völlig korrekt.

    Die Prüfung erfolgt folgendermaßen:
    Excel wird angewiesen das Jahr aus einem Datum zu extrahieren (Jahr X)
    Danach wird ein neues Datum generiert
    Tag 0
    Monat 3
    Jahr x
    Excel interessiert sich dabei wenig für unsere Kalender es ist nur ein Rechenprogramm.
    Der 0. März ist für Excel daher der Tag der vor dem 1. März liegt. Excel würde sogar negative Zahlen für den Tag akzeptieren.
    Welcher Tag liegt nun vor dem 1. März?
    In einem Schaltjahr der 29. Februar.
    Wenn es kein Schaltjahr ist, der 28. Februar.
    Die Wenn-Funktion prüft nun ob der Tag der 29. ist….

    Kurzum:
    Die Formel ist korrekt und nicht fehlerhaft.
    Und ja mit der Angabe eines beliebigen Datums kann man feststellen ob das Jahr in dem das Datum liegt ein Schaltjahr ist oder nicht.

Sekretaria-Talk: Was meinen Sie dazu?