Schaltjahre mit Excel schnell ermitteln

29. Februar, Schalttag 2016
© mitifoto / Fotolia.com

2016 – das ist ein Jahr mit einer geraden Zahl. Aber ist es auch ein Schaltjahr? Mit Excel können Sie auf diese Frage sehr schnell antworten. Die Funktionen REST und JAHR machen es möglich. Dafür müssen Sie nur ein einzelnes Datumsfeld auswählen und die entsprechenden Formeln hinterlegen. Wir stellen Ihnen zwei Varianten vor, wie Sie Schaltjahre mit Excel berechnen: einmal mithilfe des gregorianischen Kalenders und ein anderes Mal über die Anzahl der Tage im Februar.

Wie werden Schaltjahre berechnet?

Welche Jahre sind überhaupt Schaltjahre? Im Grunde gilt ja die Regel: Alle Jahre, die ohne Rest durch 4 teilbar sind, bekommen einen zusätzlichen Tag, um die Abweichungen zwischen dem kalendarischen und dem astronomischen Jahr auszugleichen. Aber es gibt eine wichtige Ausnahme, die nur wenig bekannt ist. Denn die vollen 100 Jahre sind von der Schaltjahresregelung ausgenommen. 1900 ist also zwar ohne Rest durch 4 teilbar, aber nach dieser Bestimmung doch kein Schaltjahr.

Und um es noch ein wenig komplizierter zu machen, gibt es auch hier wieder eine Ausnahme, die alle vollen Jahrhunderte betrifft, die durch 400 teilbar sind. Diese sind dann abweichend von der ersten Ausnahmen doch wieder Schaltjahre. 2000 ist so ein Fall. Es ist zwar ein volles Jahrhundert (dürfte also nach der ersten Regel kein Schaltjahr sein), aber durch 400 teilbar – und hat damit doch wieder einen Tag mehr.

Ein Schaltjahr ist also zusammengefasst wie folgt gekennzeichnet:

  1. Die durch 4 teilbaren Jahre erhalten zusätzlich einen Schalttag. Danach wären beispielsweise 1900, 2000 und 2004 Schaltjahre.
  2. Die durch 100 teilbaren Jahre bekommen diesen Schalttag wieder weggenommen. Es bliebe im Beispiel nur 2004 als Schaltjahr übrig.
  3. Schließlich wird bei den durch 400 teilbaren Jahren der Schalttag wieder zugefügt. Damit ist schließlich neben 2004 auch 2000 wieder ein Schaltjahr.

Schaltjahre mit Excel ermitteln: über den gregorianischen Kalender

Bezogen auf die Zelle A1, würde dies bedeuten, dass eine Formel mit verschiedensten Bedingungen erforderlich ist, die diese Regel und die Ausnahmen aufnimmt und eine entsprechende Schaltjahr-Information zurückgibt:
=WENN(REST(JAHR(A1);400)=0;“Schaltjahr“;WENN(UND(REST(JAHR(A1);4)=0;REST(JAHR(A1);100)<>0);“Schaltjahr“;“kein Schaltjahr“))

Schaltjahre mit Excel ermitteln: über Tage im Februar

Sie können Schaltjahre mit Excel aber auch über eine andere Formel berechnen, wie Sie am Beispiel von Zelle A2 sehen:
=WENN(TAG(DATUM(JAHR(A2);3;0))=29;“Schaltjahr“;“kein Schaltjahr“)

Achtung: Fehler in Excel

Bei diesem Lösungsansatz müssen Sie jedoch aufpassen, denn „Microsoft Excel nimmt fälschlicherweise an, dass das Jahr 1900 ein Schaltjahr ist …“ und  bei Microsoft wird auch begründet, warum dies so ist. Schuld an diesem Dilemma ist demnach nicht Microsoft, sondern die Software-Firma Lotus, die in ihrer ersten Version im Jahr 1983 in dem damaligen Tabellenkalkulationsprogramm Lotus 1-2-3 das Jahr 1900 als Schaltjahr ausgerufen hat. Aus Gründen der Kompatibilität habe man damals diese „Konvention“ übernommen. Und weil der Fehler bis heute erhalten geblieben ist, könne man den Fehler auch nicht mehr so einfach korrigieren.

Sekretaria-Talk: Was meinen Sie dazu?

Ihr persönlicher Newsletter

Ihre Vorteile

› Wöchentlich topaktuelle News
› Checklisten, Musterbriefe und Praxis-Hilfen
› Rabatte und Sonderaktionen für unsere Leser